Yii Framework Kurulumu

Merhabalar yii framework ün şuan en stabil sürümü olan versiyon 2.0.7 yi kurmak konusunda birşeyler paylaşacağım. Öncelikle composer denilen php geliştiricilerin olmazsa olmazı yazılımı indirip kurmamız gerekiyor. Composer bize yii2 framwork ün kurulumu sırasında yardımcı olacak ve daha sonra kendi geliştirdiğimiz eklentileri daha sorna kullanmak amacıyla github’a yüklemek veya ihtiyacımız olan ek bileşenleri frameworkümüzün içerisine eklememize fırsat verecektir.

Komposer kurulumu için aşağıda vermiş olduğum adresi ziyaret ediyoruz.

https://getcomposer.org/download/

Girdiğimizde en başta windows için setup var, eğer windows kullanıyorsak bu exeyi indiriyoruz. Sonrasında bilindik next next next diyerek kuruyoruz. Burada dikkat etmemiz gereken install shellmenu opsiyonu, bunu yapmazsanız kullanım açısından zorluk çekersiniz.

Composer-Setup.exe

Linux dağıtımlarınından herhangi birini kullanıyorsanız aşağıdaki adımları uyguluyorsunuz bu adımlar composer in download sayfasındada yer alıyor.

php -r "readfile('https://getcomposer.org/installer');" > composer-setup.php
php -r "if (hash('SHA384', file_get_contents('composer-setup.php')) === '7228c001f88bee97506740ef0888240bd8a760b046ee16db8f4095c0d8d525f2367663f22a46b48d072c816e7fe19959') { echo 'Installer verified'; } else { echo 'Installer corrupt'; unlink('composer-setup.php'); } echo PHP_EOL;"
php composer-setup.php
php -r "unlink('composer-setup.php');"

Evet şuanda composer i kurmuş bulunuyoruz. Windows yii2 yi kuracağımız boş bir klasör oluşturup içerisinde sağ tıklıyoruz. Burada shell menuda

"Use Composer Here"

seçeneği var tıklayarak komut ekranına ulaşıyoruz.

ilk çalıştıracağımız komut:

composer global require "fxp/composer-asset-plugin:~1.1.1"

Bu yii için gerekli global bir eklenti, sonrasında yii framework ün hangi türünü kullanmak isterse ona göre aşağıdaki kodu çalıştırıyoruz;

Basic İçin

composer create-project yiisoft/yii2-app-basic basic 2.0.7

Advanced İçin

composer create-project yiisoft/yii2-app-advanced advanced 2.0.7

Linux içinse kodları aşağıdaki şekilde çalıştırmamız gerekiyor;

php composer.phar global require "fxp/composer-asset-plugin:~1.1.1"
php composer.phar create-project yiisoft/yii2-app-basic basic 2.0.7
php composer.phar create-project yiisoft/yii2-app-advanced advanced 2.0.7

Bu işlemler bittiğinde composer yii ye ait dosyaları klasörünüzde oluşturacaktır.

Görüntülemek için;

http://localhost/yeniproje/basic/web/

start-app-installed

Güzel kodlamalar.



Bu yazı 1311 kez görüntülendi.


Bir Cevap Yazın